PAM not working after installing a patch
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PAM not working after installing a patch

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Article ID: 374551

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After installing CP08 in PAM 4.3 SP5, the services don't start and the following error appears in the c2o.log:

ERROR [com.optinuity.c2o.transport.CertificateManager] [       Timer-17] Certificate has expired - 
ERROR [com.optinuity.c2o.transport.CertificateTrustManager] [       Timer-17] Error validating server is trusted - 
java.security.cert.CertificateException: No valid certificate found in certificate chain

Environment

PAM 4.3 SP5

Cause

The certificate being used by PAM is expired

Resolution

Install valid certificates in PAM. 

For 4.3 SP5

If a Self-Signed certificate is being used, click on the following link: Self-Signed certificate 

If CA cert is being used, click on the following link: CA cert 
 

For 4.4

Manage Certificates

If PAM is integrated with SDM, refer to the following KB article to enable communication between the two applications using the new certificate(s): 

Enabling SDM to ITPAM Communications When ITPAM is SSL Enabled