Error: "Found one or more unsupported ESX/ESXi hosts" when upgrading the VMware Cloud Director
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Error: "Found one or more unsupported ESX/ESXi hosts" when upgrading the VMware Cloud Director

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Article ID: 374455

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

VMware Cloud Director upgrade failed with below error:

DB upgrade results: 
Welcome to the VMware Cloud Director upgrade utility Verify that you have a valid license key to use the version of the VMware Cloud Director software to which you are upgrading. 
This utility will apply several updates to the database. Please ensure you have created a backup of your database prior to continuing. 
Do you wish to upgrade the product now? [Y/N] 
Examining database at URL: jdbc:postgresql:/###-###-##-####/vcloud?socketTimeout=90&ssl=true 
Identifier: "4724####-####-####-######0046", Name: ######-###-###-###.com, Host version: x.x.x, Connection State: Removed, Associated vCenter Id: db51####-####-####-######1ebf 
Found one or more unsupported ESX/ESXi hosts.
Please answer y or n. 
Found one or more unsupported ESX/ESXi hosts.
One or more ESX/ESXi hosts registered to this VMware Cloud Director installation are not supported by the version of VMware Cloud Director you are upgrading to. Upgrade cancelled. 
Please restart VMware Cloud Director and follow the procedures in the ESX/ESXi Upgrade Guide to upgrade those unsupported ESX/ESXi hosts to a supported version x.x or later. 
Ensure that the new version is reflected back to VMware Cloud Director before its shut down and upgrade is re-attempted.

 

Environment

VMware Cloud Director 10.x

Cause

  • ESXi host is not in compatible version. 
  • There are stale ESXi host present in the vCenter. 

Resolution

Verify if all the hosts are in compatible version. 

Verify if there are any stale hosts present in the vCenter. 

For further assistance contact technical support and note this Knowledge Article ID (374455) in the problem description. For more information, see How to Submit a Support Request