Error: "Your account has expired: please contact your system administrator. su: User account has expired" is reported upon login as postgres user
book
Article ID: 374310
calendar_today
Updated On:
Products
VMware Cloud Director
Issue/Introduction
- During login to the postgres user account the following message appears
Your account has expired: please contact your system administrator.
su: User account has expired
- In a Cloud Director database cluster one cell reports a failure connecting to another cell over SSH port 22 with the postgres account.
- Database switchover between the primary and a standby cell is not possible.
Cause
This issue occurs if the postgres user account has expired.
Resolution
- Access the command line of the impacted Cloud Director cell and login as root user.
- Run the following command to review the current postgres account details
chage -l postgres
- Within the output confirm that "Account Expires" date is in the past.
- Update the account expiry to 'never' using the following command.
chage -E -1 postgres
- Confirm the change is applied
chage -l postgres
Additional Information
The postgres user password can be set to never expire using the following command if required.
chage -M -1 postgres
Feedback
thumb_up
Yes
thumb_down
No