Unable to resolve Configuration State Mismatch after syslog server is configured in NSX Edge CLI
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Unable to resolve Configuration State Mismatch after syslog server is configured in NSX Edge CLI

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Article ID: 374170

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX Edge has 2 or more entries for specific level.
    For example, following configuration has 2 entries.
    set logging-server <syslog-server-ip> proto udp level info facility auth
    set logging-server <syslog-server-ip> proto udp level info structured-data audit="true"
    set logging-server <syslog-server-ip> proto udp level err
  • Unable to resolve configuration mismatch on UI.
  • UI shows Configuration State is Mismatch at Systme > Fabric > Nodes > Edge Transport Nodes.
  • Click RESOLVE button with Source vSphere/Edge Appliance at Resolve Sync Errors modal gives following error.
    Error: [Fabric] Duplicate syslog server
    com.vmware.nsx.management.policy.edge.model.SyslogConfiguration@879e5722 configured in syslog configuration.
    (Error code: 16074)
  • /var/log/proton/nsxapi.log shows following error
    <TIME_STAMP>  INFO http-nio-127.0.0.1-7440-exec-7 NsxBaseRestController 4813 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subco
    mp="manager"] Error in API /nsxapi/api/v1/transport-nodes/<Transport_Node_ID>?action=refresh_node_configuration&resource_type=
    EdgeNode&read_only=false caused by exception com.vmware.nsx.management.common.exceptions.InvalidArgumentException:  {"moduleName":"FABRIC","err
    orCode":16074,"errorMessage":"[Fabric] Duplicate syslog server com.vmware.nsx.management.policy.edge.model.SyslogConfiguration@879e5722 configu
    red in syslog configuration."}

Environment

NSX 4.x, NSX-T Data Center 3.x

Cause

NSX Manager compares configuration between Manager itself and Edge.
Configuration State column in UI shows resolve option if there is a mismatch between Manager and Edge so that administrator can manually decide which one is correct.

Since Edge has more detailed configuration options such as facility or structured-data that Manager does not handle, choosing Edge configuration source results in duplicated entries on Manager.

For example, Edge is configured with following:

set logging-server <syslog-server-ip> proto udp level info facility auth
set logging-server <syslog-server-ip> proto udp level info structured-data audit="true"
set logging-server <syslog-server-ip> proto udp level err

Manager receives duplicated entries such as:

"syslogServer": [
  {
    "server": "<syslog-server-ip>",
    "port": 514,
    "protocol": "SYSLOG_PROTOCOL_ENUM_UDP",
    "logLevel": "SYSLOG_LEVEL_ENUM_INFO"
  }, 
  {
    "server": "<syslog-server-ip>",
    "port": 514,
    "protocol": "SYSLOG_PROTOCOL_ENUM_UDP",
    "logLevel": "SYSLOG_LEVEL_ENUM_INFO"
  },
  {
    "server": "<syslog-server-ip>",
    "port": 514,
    "protocol": "SYSLOG_PROTOCOL_ENUM_UDP",
    "logLevel": "SYSLOG_LEVEL_ENUM_ERROR"
  } 
]

As result, there are 2 entries for INFO Log Level, UDP Protocol.
Manager validates the same entries as duplicated and rejects the resolve request.

Resolution

Currently, there is no resolution.

If only following entries are required, configure through Node Profile:

  1. FQDN or IP Address
  2. Port
  3. Protocol
  4. Log Level

If you need to use Edge CLI to configure including options such as facility or structured-data, Contact Broadcom Support.