Data not getting collected for NSX-T edge gateway for "statistics|uplink|Bandwidth Out and statistics|uplink|Bandwidth In " in Aria Operations
search cancel

Data not getting collected for NSX-T edge gateway for "statistics|uplink|Bandwidth Out and statistics|uplink|Bandwidth In " in Aria Operations

book

Article ID: 374158

calendar_today

Updated On:

Products

VMware Aria Suite VMware Aria Operations (formerly vRealize Operations) 8.x VMware Aria Operations 8.x VMware NSX VMware NSX-T Data Center

Issue/Introduction

  • We can see that data collection is happening for the NSX-T adapter.
  • We can confirm that the metric collection is enabled at policy level as well.
  • We have tried to stop and start collection for the adapter, still the same issue.
  • If we check on the "number metrics" getting collected it will show correct value for the selected gateway.

Environment

Aria Operations 8.x

Cause

  • If we do not find any issues in data collection at the Aria operations end.
  • The issue is most likely at NSX-T end where the API calls are not sending updated data.
  • NSX API response does not get updated from long time (weeks/months) for the router link interface associated with the logical router.
  • Hence Aria Operations is getting the same cumulative values and hence discrete values which is the difference between current cycle cumulative value and previous cycle cumulative values is 0.
  • We can check on this using below API calls to NSX-T manager directly

    Call 1 : Fetch Router ports for logical router in context.[ <router_id> can be fetch from NSX UI for a given logical router or via API (api/v1/logical-routers)or even from vROps Inventory>Router Resource in context>Identifier 2 (filter the columns to display identifiers)]
    https://<nsx_ip>/api/v1/logical-router-ports?logical_router_id=<router_id>

    Call 2: For each router port fetch in the statistics
    https://<nsx_ip>/api/v1/logical-router-ports/{logical-router-port-id}/statistics/summary
  • Below is an example output of call 2:

    {
        "logical_router_port_id": "########-####-####-####-############",
        "last_update_timestamp": ############,
        "rx": {
            "total_bytes": 63311121115,
            "total_packets": 191855117,
            "dropped_packets": 72240212
        },
        "tx": {
            "total_bytes": 51581674744,
            "total_packets": 195849202,
            "dropped_packets": 3706349
        }
    }
  • As we can see the last_update_timestamp value is ############ (Epoch time), which translates to Monday, July 15, 2024 6:35:42.041 PM GMT, this means we have had no update since July 15 2024.

Resolution

If we observer the above results when trying to run the API calls to NSX-T, have customer involve NSX-T support to investigate the issue further at NSX-T layer.