SDC debug showing EPREC_SOCKET_ERROR
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SDC debug showing EPREC_SOCKET_ERROR

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Article ID: 374076

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Updated On:

Products

DX NetOps CA Spectrum

Issue/Introduction

It was found that a previously configured SDC would not connect to the SDM secure domain manager on the SpectroSERVER.  There were multiple SDC IP addresses configured in the sdm.config file. 

We added debug to the sdm.config and sdc.config:

-loglevel debug

Reimported the sdm.config on the SS and restarted the SDMConnector service on the SDC.

The debug in the sdm.log showed a connection to all SDC except for one.  The connection debug for the IP of the SDC in question shows:

EPREC_SOCKET_ERROR

When running netstat and grepping for port 6844 you can see ESTABLISHED for the working SDC IP.  For the non working SDC IP you see SYN_SEN

Cause

Firewall blocking port 6844

Resolution

Update the firewall to allow traffic on port 6844