Error "Unable to tunnel through proxy. Proxy returns "HTTP/1.1 503 Service unavailable" when trying to add/create vCenter Cloud Account or Aria Operations Integration in Aria Automation.
Attempting to configure a vCenter Cloud Account or an Aria Operations integration within Aria Automation, the process fails with the following error:
"Unable to tunnel through proxy. Proxy returns 'HTTP/1.1 503 Service unavailable'"
The service account that connects the Aria Automation to the vCenter / Aria Operations has the correct credentials and privileges.
The connection between the Aria Automation and the vCenter / Aria Operations telnet/curl fails to validate a connection over port 443.
curl -v https://<FQDN_VRA>:443
Environment
Aria Automation 8.18.x
Cause
This can happen if the Aria Automation does not have connectivity to the vCenter / Aria Operations and port 443 over HTTPS is not opened.
Resolution
This is a firewall issue. Aria Automation requires HTTPS (Port 443) access to vCenter and Aria Operations. Ensure Port 443 is open from the Aria Automation nodes (or Cloud Proxy) to the respective destination FQDNs before adding the cloud account or integration.