Inventory Sync Issue between VMware Identity Manager and Lifecycle Manager post IP Change of VMware Identity Manager appliance.
search cancel

Inventory Sync Issue between VMware Identity Manager and Lifecycle Manager post IP Change of VMware Identity Manager appliance.

book

Article ID: 373985

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

After performing a network migration to update the IP addresses of the VMware Identity Manager (vIDM 3.3.x) it was no longer syncing correctly with the Aria Suite Lifecycle Manager.

Environment

VMware Identity Manager 3.3.x - Single node Environment

Cause

In debugconfig.txt log we will be able to see 2 cluster instance with both new (ip: ##.###.#.##) and old(ip: xx.xxx.x.xx) addresses.

[ 
  { 
     "version": "3.3.7.0 Build 21173100", 
     "uuid": "xxxxxxxxx-xxxxxxxxxx-xxxxxxxxx-xxxxxxx", 
     "status": "Active", 
     "lastUpdated": <Date>, 
     "hostname": "<vIDM-Hostname>", 
     "datacenterId": <ID>, 
     "id": <ID>, 
     "ipaddress": "##.###.#.##" 
  }, 
  { 
     "version": "3.3.7.0 Build 21173100", 
     "uuid": "xxxxxxxxx-xxxxxxxxxx-xxxxxxxxx-xxxxxxx", 
     "status": "Active", 
     "lastUpdated": <Date>, 
     "hostname": "<vIDM-Hostname>", 
     "datacenterId": <ID>, 
     "id": <ID>, 
     "ipaddress": "xx.xxx.x.xx"  
  } 
]  

Resolution

In order to resolve this issue please follow the below recommendation:

Make sure to have a VMware Identity Manager Appliance snapshot.

  • Check and Update Service Instances:

    • Connect to the PostgreSQL database on the vIDM appliance using psql:
      psql -U postgres;
      select * from "ServiceInstance";
    • Ensure that the service instance table only contains entries with the new IP addresses. If there are old IP addresses present, delete them after taking a snapshot of the appliance.
  • Manual Verification and Reconfiguration:

    • Re-add the VMware Identity Manager vAPP options manually if they were removed during the migration.
    • Confirm that Aria Suite Lifecycle Manager and VMware Identity Manager are correctly configured to communicate with each other using the new IP addresses.
  • Retry Synchronization:

    • After making the above updates, retry the Inventory sync for the VMware Identity Manager from the Aria Suite Lifecycle Manager.