Alarms from UIM synchronized to SOI are delayed
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Alarms from UIM synchronized to SOI are delayed

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Article ID: 373971

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

SOI is configured using the Catalyst Connector to sync alarms from UIM.  Alarms triggered in UIM are arriving in SOI, but they are delayed.  Over time and depending upon the number of UIM alarm closures, the delay increases by as much as several hours in a single day.  Restarting the connector resynchronizes the alarms, but the delay again increases until the connector is restarted again.

Environment

SOI 4.2 CU5
CatalystConnector 3.9.3.0

Cause

SOI does not have a severity level of "information" for alarms.  Therefore, UIM information alarms are not synchronized from UIM into SOI. 

The clear message for UIM alarms do not have severity included.  As the connector receives a clear alarm, it is unable to determine the severity.  Because UIM informational alarms do not exist in SOI, when a clear alarm for informational severity alarms is received, the Connector continues to retry these alarm closures, but is unable to find the alarm in SOI.  A high count of informational alarm closures and the retries of these alarm closures are causing the delays.

Resolution

A fix has been attached to this article that drops alarms from the queue if they do not match an existing alert in SOI.

  1. Stop the Catalyst connector where UIM connector is installed
  2. Take a backup of below jar file:
    CA\Catalyst\CatalystConnector\Container\system\com\ca\catalyst\3.0.0\bundles\nimsoftconnector.jar
  3. Download and unzip the file attached to this article
  4. Copy and replace the .jar file in step 2 with the nimsoftconnector.jar file attached to the article
  5. Start the Catalyst connector.

The Catalyst connector will now ignore UIM clear alarms that do not exist as a SOI alert (including UIM informational alarms).

Attachments

nimsoftconnector.zip get_app