Cross vCenter VM migration fails with the error "Cannot connect to host"
search cancel

Cross vCenter VM migration fails with the error "Cannot connect to host"

book

Article ID: 373947

calendar_today

Updated On:

Products

VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0

Issue/Introduction

This article addresses the issue of VM migration failure between vCenter servers using advanced cross vCenter migration. The migration process fails at 37% with the error "Cannot connect to host." 


Cause

The migration failure is caused by the source host being unable to communicate with the destination host via TCP port 902. While port 902 may be open for UDP, if it is not open for TCP, which is required for vMotion to function correctly, we can see the migration failing. 

Resolution

1. Verify Network Connectivity:

Ensure that the vMotion and Management networks between the source and destination hosts are reachable with vmkping.

2. Check Port 902:

  1. Verify that port 902 is open via the TCP protocol.
    nc -vz <HostIPAddress> 902
  2. If the connection fails, then the port is possibly blocked. 

TCP port 902 must be open for both UDP and TCP protocols for vMotion to function correctly.

3. Open the TCP port 902 on Firewall rules