Emails do not get delivered from Jaspersoft server
search cancel

Emails do not get delivered from Jaspersoft server

book

Article ID: 373929

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Emails do not get delivered from the Jaspersoft server. All the relevant configurations are in place. The jasperserver.log shows the following message:

1914-03-19T14:24:55,143 ERROR ReportExecutionJob,quartzScheduler_Worker-1:457 [] - The job error notification was not completed. An error occurred while sending it.
org.springframework.mail.MailSendException: Mail server connection failed; nested exception is javax.mail.MessagingException: 501 5.5.4 Invalid domain name

Cause

The following is a response obtained from the Mail server:

501 5.5.4 Invalid domain name

The issue is not specific to the Jaspersoft / Clarity application. A simple Java program to send an email also encounters this same message.

Resolution

  • Work with infrastructure to resolve the issue
  • Sending an email via Telnet might work. But to recreate the correct scenario, use a program written in Java, or another similar language to test
  • This could possibly be an issue with the server's name. It might not be sending across its Fully Qualified Domain Name.

Additional Information

  • A scenario has been noticed where commenting out the internal IP of a server in the hosts file results in this issue.