Aria Suite Lifecycle Manager appliance network configuration lost after upgrading from version 8.16.0 to 8.18.
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Aria Suite Lifecycle Manager appliance network configuration lost after upgrading from version 8.16.0 to 8.18.

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Article ID: 373903

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

After upgrading the Aria Suite Lifecycle Manager appliance from version 8.16.0 to 8.18, the network configuration (IP address, netmask, and gateway) is lost after rebooting, restricting the services from getting started.

-ifconfig on VM shows local loopback and IP address of 127.0.0.1


-service network status shows Active: inactive (dead)
-Running command /opt/vmware/share/vami/vami_config_net option 0 shows no networking assigned to the VM

Environment

Aria Suite Lifecycle Manager (LCM) (vRSLCM) (vRLCM) 8.18

Cause

The problem is related to a known issue in the Photon OS handling of network services post-upgrade.

Resolution

To resolve the issue of network configuration loss, the following steps are recommended:

  • Take a snapshot of the Aria Suite Lifecycle Manager appliance
  • After rebooting Aria Suite Lifecycle Manager 8.18, manually restart the network service by executing:
systemctl restart systemd-networkd
  • This command should be executed each time the appliance is rebooted to restore network connectivity.

To ensure a persistent workaround post reboot:

  1. Ensure the connect at power on box is checking in vSphere under VM settings.
  2. Open remote console to the VM, and run the command service network start
  3. Run /opt/vmware/share/vami/vami_config_net and then go through the options to set the networking again.

Next, we will add a crontab entry to automatically run the systemctl restart systemd-networkd command on boot

  1. Run the command crontab -e to edit the system cron
  2. Type i to enter insert mode
  3. Enter the following line @reboot systemctl restart systemd-networkd
  4. Type :wq! to write, save, and quit