VIP AuthHub - newly register user got access denied
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VIP AuthHub - newly register user got access denied

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Article ID: 373872

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Updated On:

Products

VIP Authentication Hub

Issue/Introduction

Some of the newly registered users get access denied by VIP AuthHub.

VIP AuthHub integrated with Siteminder through MFA auth scheme where siteminder performs primary auth via password authentication and VIP AuthHub performs the second factor email OTP.

For the failing users, they were getting to "enter your password" signing screen instead of the email OTP signing screen.

msgUser with loginId 'xxxxxxx' with internal userid 'xxxxxxxx-347c-4f44-a389-xxxxxxxxx' is inactive 

Environment

All VIP AuthHub releases 

Cause

This Issue can be caused by either duplicate accounts in the VIP AuthHub user Directory or by the user Account status as INACTIVE 

Resolution

To check the User account status through VIP AuthHub, the following API can be used :  Local user account management --> search users by Filter -->  https://{{sspHost}}/{{apiPathTenant}}/admin/v1/Users?filter=user_universalId   Or by using the "get user by login ID"  API.

The above will show the status of the user if marked as INACTIVE which is the case from the reported error message and resolved by setting the user as ACTIVE through the lock/unlock API