bindaddress value not used as preferred IP address
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Article ID: 373857
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Updated On:
Products
CA Configuration Automation
Issue/Introduction
Agent has 2 ipaddress : A1 and A2
in agent.conf, bindaddress value is set to A2
bindaddress=A2
But in Configuration Automation UI, Agent is reported with IP Address A1
In Agent.log there are these lines :
2024-08-05 10:35:54 :DEBUG:p8675:t-139565312: found IPv4 address: A1 2024-08-05 10:35:54 :DEBUG:p8675:t-139565312: found IPv4 address: A2 ... 2024-08-05 10:35:54 :INFO:p8675:t-139565312: hostname = <Computer1>, preferred IP address = <A1> 2024-08-05 10:35:54 :INFO:p8675:t-139565312: CCagent OK(socket = 3): listen on port 8063
Preferred IP Address is A1 and not A2 (as defined in bindaddress in agent.conf)
But in result of netstat command A2 address is used for listening on port 8063
tcp 0 0 A2:8063 0.0.0.0:* LISTEN off (0.00/0/0)
Environment
Configuration Automation 12.9
Agent Version 12.9.0.54 on Windows and Linux
Cause
Upon starting, the agent retrieves the list of IP address by calling an OS Function. The first valid IP Address returned is used and sent as preferred IP address to the server
The bindaddress value set in agent.conf is not used at startup of Agent. It is used after, Agent is using this ipaddress for listening incoming connections with port 8063
Resolution
New Agent version 12.9.0.117 changes the behavior like this :
If bindaddress is specified in agent.conf, it is used as "preferred IP address"
If bindaddress is not specified, "preferred IP address" is the first valid IP Address returned by the call of a OS function.
Open a case at Broadcom Technical Support to ask the version of Agent 12.9.0.117 Then reinstall the agent with this new version