CA Service Desk maileater fail to connect to Mailserver.
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CA Service Desk maileater fail to connect to Mailserver.

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Article ID: 373852

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Maileater unable to connect to  Email server and fail to create tickets.

Environment

CA Service Desk Manager 17.4.X 

Cause

2024-07-18 13:43:56:114 ERROR  [ForkJoinPool-1-worker-51] c.c.S.m.c.JavaMailIMAPClient - [ID:([email protected]),HN:([email protected]))] -> [IMAPS|993] Failed to connect to the Store.

javax.mail.MessagingException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

    at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:718)

    at javax.mail.Service.connect(Service.java:342)

Resolution

Steps: 

  1. Copy the certificate [email protected].   from D:\certs\[email protected]  to  NX_ROOT\[email protected].
  2. Update the mailbox certificate path with just the name of the certificate :[email protected].  




  1. pdm_bounce pdm_maileater 

 

Additional Information

The maileater certificate is stored in the internal nx.keystore.  Please review the KB Article keystores and certificate verification in Service Desk Manager for information about the internal nx.keystore and how to examine its contents.