AD users unable to login to Enforce console
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AD users unable to login to Enforce console

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Article ID: 373839

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Updated On:

Products

Data Loss Prevention Core Package

Issue/Introduction

AD users unable to login to Enforce console with the following error. 

Environment

DLP 15.8 and later

Cause

The built-in active oracle connection pool has been exhausted. This setting is set via the OJB.properties file

Resolution

The manager_jdbc_0.log showed signs of database connections pool exhaustion in the Apache OJB pool. The JDBCLogger shows numerous inactive, possibly abandoned connections. We followed below steps to increase the maxActive limit for pool using below steps:

1. Navigate to <Install Drive>\Symantec\DataLossPrevention\EnforceServer\<version>\Protect\config\OJB.properties
 
# maximum number of brokers that can be borrowed from the
# pool at one time. When non-positive, there is no limit.
maxActive=50
 
2. Increase this setting by 25

3. Restart the Symantec DLP Manager service and the issue got resolved.

4. Repeat steps 2 and 3 as needed until stability is achieved. 

*Note, if utilizing the DLP Core API, ensure that you are either re-using sessions or logging out at the end of any automated API commands, this can help prevent connection pool exhaustion. 

 

Additional Information

The oracle-side session configuration can also be pulled as part of the 'Get Full Report