HCX - OSAM - Failed to perform fix-up operation on migrated VM. Failed to prepare for Fixup -- Unable to login with vmuser
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HCX - OSAM - Failed to perform fix-up operation on migrated VM. Failed to prepare for Fixup -- Unable to login with vmuser

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Article ID: 373811

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Updated On:

Products

VMware HCX

Issue/Introduction

Unable to Migrate VM using OSAM. Fails with above error. 

- Review app.log : /common/logs/admin/app.log

Cloud HCX-MGR :

2024-07-03 03:03:42.596 UTC [OsAssistedMigrationService_SvcThread-1599, Ent: HybridityAdmin, , TxId: TxId: ########-####-####-####-1d99e6b98ada] WARN  c.v.v.h.s.m.jobs.WindowsFixupJob- doWaitForReadyToFixup() - Failed to run SOAP request ListFilesInGuest The guest operations agent could not be contacted. migrationId: ########-####-####-####-5465607e89c9

Review Sentinel logs on Source VM for more details. In this case we saw errors indicating a failure to login with local user "vmwuser" which is created by OSAM workflow on destination VM using attached installer. 

Sentinel agent log location:

Windows:

  • C:\ProgramData\VMware\HCX

Linux: 

  • /var/log/vmware/hcx/

Environment

HCX 4.x

Hyper-V source VM

Cause

An unknown configuration on the Windows OS (suspecting Group Policy restrictions for local users).

 

Resolution

Install VMware tools manually on the Source machine prior to starting OSAM migration. 

Pre-requisites:

  1. Open the VMware tools MSI file using Orca.
  2. On the left hand side, find the entry "InstallUISequence"
  3. Find the entry "VM_CheckRequirements"
    1. Right click on this entry and select "drop row"
      1. For VMware tools 11.x and above you will need to find and drop the "VM_LogStart" row from the "CustomAction" table as well.
  4. Save and exit Orca

Copy all 3 files to your Hyper-V machine:

  • vcredist_x64.exe
  • vcredist_x86.exe
  • VMware Tools64.msi  -- modified

Install VMware tools using the modified MSI. 

 

NOTE:

The above method should only be performed as a last resort. Any issues that occur from force installing VMware tools on the source machine will NOT be investigated by Broadcom. 

Every effort should be made to investigate why the OS is blocking the login for local OSAM user 'vmuser' - which in-turn blocks the installation of VMware tools on destination.