Module association with Target Permissions
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Module association with Target Permissions

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Article ID: 373803

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Updated On:

Products

CA Identity Suite

Issue/Introduction

Target Permissions database, although associated with the Execution Plans in the portal, is not visible in the access module until a manual change is made to the Execution Plans

Cause

The issue arises because the client is generating the target permissions in batch and cannot associate them with the Execution Plan in batch. The client wants to know if there is a way to perform this association in batch.

Resolution

Here are a few steps you might consider troubleshooting and resolve this issue:

1 - Go first in Elements -> Target Permissions and create your target permissions. For example, "TP_CAIM_ADMIN_ROLE_Access Request ApproverII"
2 - In a second step export the json file from Setup -> Tools -> Export and select only the Access Rights. 

3 - Add the "TP_CAIM_ADMIN_ROLE_Access Request ApproverII" to Access Rights. For example, using the number 655 but you need to check what the next id number if for your environment in your Json file.
{
    "description": null,
    "date": 1722269791718,
    "export": [
        {
            "id": 602,
            "tag": "AG_catalog1",
            "typeClass": "com.idmlogic.sigma.model.exportable.migration.Group",
            "type": "GROUP",
            "localizations": [],
            "name": "catalog1",
            "groupType": "APPLICATION_GROUP",
            "extensions": [],
            "order": "10"
        },
        {
            "id": 652,
            "tag": "PERM_catalog1application1_catalog1application1permission1",
            "typeClass": "com.idmlogic.sigma.model.exportable.migration.Permission",
            "type": "PERMISSION",
            "localizations": [],
            "name": "catalog1application1permission1",
            "applicationTag": "APP_catalog1application1",
            "parentTag": null,
            "permissionGroupTag": null,
            "owner": null,
            "admin": null,
            "order": "10",
            "targetPermissionsTags": [
                "TP_CAIM_ADMIN_ROLE_Access Request Approver"
            ],
            "permissionProperties": {},
            "strongAuthTags": [],
            "extensions": [],
            "statisticsCategoryName": [],
            "statisticsStatus": "DEFAULT"
        },
        {
            "id": 627,
            "tag": "APP_catalog1application1",
            "typeClass": "com.idmlogic.sigma.model.exportable.migration.Application",
            "type": "APPLICATION",
            "localizations": [],
            "name": "catalog1application1",
            "applicationGroupTag": "AG_catalog1",
            "applicationProperties": {},
            "extensions": [],
            "order": "10"
        },
        {
            "id": 653,
            "tag": "PERM_catalog1application1_catalog1appliation1permission2",
            "typeClass": "com.idmlogic.sigma.model.exportable.migration.Permission",
            "type": "PERMISSION",
            "localizations": [],
            "name": "catalog1appliation1permission2",
            "applicationTag": "APP_catalog1application1",
            "parentTag": null,
            "permissionGroupTag": null,
            "owner": null,
            "admin": null,
            "order": "5",
            "targetPermissionsTags": [
                "TP_CAIM_ADMIN_ROLE_Use Cases - Self"
            ],
            "permissionProperties": {},
            "strongAuthTags": [],
            "extensions": [],
            "statisticsCategoryName": [],
            "statisticsStatus": "DEFAULT"
        },
        {
            "id": 654,
            "tag": "PERM_catalog1application1_catalog1appliation1permission2",
            "typeClass": "com.idmlogic.sigma.model.exportable.migration.Permission",
            "type": "PERMISSION",
            "localizations": [],
            "name": "catalog1appliation1permission3",
            "applicationTag": "APP_catalog1application1",
            "parentTag": null,
            "permissionGroupTag": null,
            "owner": null,
            "admin": null,
            "order": "5",
            "targetPermissionsTags": [
                "TP_CAIM_ADMIN_ROLE_Use Cases - Self2"
            ],
            "permissionProperties": {},
            "strongAuthTags": [],
            "extensions": [],
            "statisticsCategoryName": [],
            "statisticsStatus": "DEFAULT"
        },
        {
            "id": 655,
            "tag": "PERM_catalog1application1_catalog1appliation1permission2",
            "typeClass": "com.idmlogic.sigma.model.exportable.migration.Permission",
            "type": "PERMISSION",
            "localizations": [],
            "name": "catalog1appliation1permission4",
            "applicationTag": "APP_catalog1application1",
            "parentTag": null,
            "permissionGroupTag": null,
            "owner": null,
            "admin": null,
            "order": "5",
            "targetPermissionsTags": [
                "TP_CAIM_ADMIN_ROLE_Access Request ApproverII"
            ],
            "permissionProperties": {},
            "strongAuthTags": [],
            "extensions": [],
            "statisticsCategoryName": [],
            "statisticsStatus": "DEFAULT"
        }
    ]
}

3 - Go to Setup -> Tools -> Import to load the json file.

Additional Information

Backup your DB before import just in case you need rollback and do this first in Test environment before to do in Production.