new hub communication error - no contact
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new hub communication error - no contact

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Article ID: 373801

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

New hub installed at remote site yields a communication error.   

Attempting to add Name Services entry from the primary hub but it is unable to connect.

Hub log shows error connecting to its own IP address:

Controller: hub (HUBNAME)(IP ADDRESS) NO CONTACT (communication error)

Hub also appears to be starting the spooler even though the hub probe should be taking over that functionality:

Controller: _ProcStart - Probe 'spooler' - starting

 

Cause

Robot was configured to point to itself for hubip/hubrobotname, but the hub probe was not actually installed.

The presence of the "Probe 'spooler' - starting" message indicates that the hub probe is actually not present and that this robot is only a standalone robot as opposed to a hub. 

Most likely, the wrong option was chosen in the installer (Robot instead of Infrastructure/hub) or the wrong installer was used (Nimbus Robot.exe instead of Nimbus Infrastrcture.exe)

 

Resolution

Reinstall using the correct installer and/or ensure the correct options are chosen to deploy Hub/Infrastructure.