CSV results are not matching the Affected Resources page in Notifications
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CSV results are not matching the Affected Resources page in Notifications

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Article ID: 373795

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Updated On:

Products

CloudHealth

Issue/Introduction

When downloading a CSV from the Notification page, the spreadsheet results do not always match the results from the Affected Resources page. 

 

We can see an example of a notification displaying 71 Affected Resources. 

 

However, the CSV spreadsheet only displays 9 instances.

 

Cause

The downloaded results on the CSV are directly from the CloudHealth API based off any exclusions or updates made from the point the download is queued.  This is why the downloaded CSV does not always match the Affected Resources in the policy Notification. 

 

The notification from the example is dated 4/15/24.  Since then, 64 instances have been excluded and can be found under the Affected Resources page within the policy block:

 

Here are the 9 instances found in the CSV spreadsheet. 

Resolution

To view Affected Resources on the day the notification occurred:

Dashboard > Notifications > click the eye icon > Affected Resources (not the Download results)

 

To view Affected Resources of the current point in time (now): 

1. Dashboard > Notifications > click the eye icon > Affected Resources > Download > Download as CSV or Send to Google Drive. 

2. Governance > Policies > eye icon of policy > click anywhere on Policy Block square (not the Policy Block Name or the Updated At hyperlink) > View All (next to Affected Resources) > Show dropdown will show currently excluded resources. 

Additional Information

Please note that instances between the Affected Resources Notification page may not be present in the Downloads and vise versa. This can be due to any instances that have been activated or deactivated after the date of the notification. 

 

Is there a way to download the Affected Resources from the Notification page to show the affected resources flagged on the day the notification occurred?

At this time, there is no option to download the affected resources from the date of the actual notification, as downloading these results will show the affected resources in real-time, taking into account any exclusions, activated/deactivated instances since the notification date.  This is only available in the UI, but can be manually copied and pasted into a spreadsheet if needed. 

Dashboard > Notifications > click the eye icon > Affected Resources