IOFilters VIB Installation on VUM Clusters Fails with "Unable to access agent offline bundle" after Updating to vCenter Server 8.0 U3
search cancel

IOFilters VIB Installation on VUM Clusters Fails with "Unable to access agent offline bundle" after Updating to vCenter Server 8.0 U3

book

Article ID: 373756

calendar_today

Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

IOFilter VIB installation after updating to vCenter 8.0 U3 is blocked. 

The Install agent event fails with the below error:

"Cannot complete the operation. See the event logs for details."

In the vSphere ESX Agent Manager pane, the Issue pane will show the following error:

"Unable to access agent offline bundle at http://<##.##.##.##:####/vib-tmp-#####/plain.zip"

The EAM logs on vCenter Server will show the following log snippet [/var/log/vmware/eam/eam(-%s).log]:

 | ERROR | host-agent-0 | AuditedJob.java | 106 | JOB FAILED: [#348333997] InstallHostAgentJob(HostAgent(ID: 'Agent:f62cb3f7-34cb-403e-bc55-43bb1ef1789a:null'))
com.vmware.eam.EamAppException: Could not complete AgentWorkflowJob because of[
eam.issue.CannotAccessAgentVib {
   description = '<esxupdate-response>
<version>1.50</version>
<error errorClass="MetadataDownloadError">
  <errorCode>4</errorCode>
  <errorDesc>Failed to download metadata.</errorDesc>
  <url>https://<VC_IP>:9087/eam/vib?id=<UNIQUE_ID></url>
  <localfile>None</localfile>
  <msg>('https://<VC_IP>:9087/eam/vib?id=<UNIQUE_ID>', '/tmp/tmpr7oo2phy', '&lt;urlopen error timed out&gt;')</msg>
</error>
</esxupdate-response>
',
   time = <TIMESTAMPT>,
   key = 0,
   agency = 'Agency:<ID>:null',
   solutionId = 'VirtualCenter',
   agencyName = 'IoFilter-<Solution_name>',
   solutionName = 'VirtualCenter',
   agentName = '<ID>',
   agent = 'Agent:<ID>:null',
   host = 'HostSystem:host-##:<SERVER_GUID>',
   hostName = '<HOST_IP>',
   downloadUrl = '<VIB_PAYLOAD_URL>',
}

Environment

vCenter Sever 8.0 U3 or higher

Firewall between vCenter Server and ESXi blocking port 9087

Cause

In 8.0 U3, EAM started using port 9087 to download VIBs.

Resolution

There is no resolution to this issue.

Workaround

To workaround this problem, open port 9087 on the firewall between vCenter Server and ESXi.