Error: UPGRADE FAILED: pre-upgrade hooks failed: job failed: BackoffLimitExceeded from 3.1.1 to 3.2.0
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Error: UPGRADE FAILED: pre-upgrade hooks failed: job failed: BackoffLimitExceeded from 3.1.1 to 3.2.0

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Article ID: 373749

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Updated On:

Products

VIP Authentication Hub

Issue/Introduction


Running upgrading VIP Authentication Hub from 3.1.1 to 3.2.0, then the upgrade command fails and shows the error:

Error: UPGRADE FAILED: pre-upgrade hooks failed: job failed: BackoffLimitExceeded

The command is:

# helm upgrade ${RELEASENAME} ssp_helm_charts/ssp -n ${NAMESPACE} -f ssp-override.yaml --version ${VERSION} --timeout=20m --set ssp.featureFlags.dataseed.enabled=true

{"timestamp":"2024-07-26T11:42:55.642470Z","type":"log","level":"fatal","thread":"main","msg":"Deployment's ssp.ingress.host property (SSP_SERVICE_PROVIDER_FQDN=ssp-1.example.com) does not match the value stated in DB (ssp-2.example.net). Use --set ssp.global.forceIngressHostOverride=true to force a change to the deploymentServiceProviderFQDN db value"}

The correct FQDN in this error msg is ssp-1.example.com.

Cause


According to the documentation, when the helm "ssp.ingress.host" value doesn't match the one written in the DB, then this error will appear (1). This can be overridden by using the parameter --set ssp.global.forceIngressHostOverride=true (2).

So, if the new FQDN of VIP Authentication Hub is ssp-1.example.com and the one written in the DB is ssp-2.example.net, then, set the parameter to the helm command.

Check the value written in the DB by running the getGlobalSettings API and check for the value of "deploymentServiceProviderFQDN":

GET https://{{sspMgmtHost}}/system/admin/v1/Settings

 

Resolution


Add --set ssp.global.forceIngressHostOverride=true to the helm command to fix this issue;

 

Additional Information