Error: "Network network-#####is not found in the inventory" when creating a VM
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Error: "Network network-#####is not found in the inventory" when creating a VM

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Article ID: 373679

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When deploying the VM in VMware Cloud Director (VCD) you have the error below:
    Network "network-#####" is not found in the inventory.

  • The VM is correctly created in vCenter and in VCD.

 

Environment

VMware Cloud Director 10.4.x
VMware Cloud Director 10.5.x


Cause

During registration of vCenter, a "None" network is defined for any VM that is deployed with the Network None.

There have been two identified causes of the missing reference.

1. The network referenced in error has been deleted in vCenter.

2. vCenter changed the Network moref and due to an underlying communication issue between vCenter and VCD reference is not updated.

Resolution

  1. Note the network referenced in VMware Cloud Director database running the steps below:

    1.1 SSH VCD primary cell

    1.2 Connect to DB running the command below:
    su - postgres psql vcloud

    1.3 Check  the  network referenced in VMware Cloud Director database running the query below:
    select name,vc_none_network_name,vc_none_network_moref  from virtual_center;

    1.4 Exit the database running the command below:
    \q

  2. On vCenter check if the referenced network from step 1 exists and follow one of the options below depending on the scenario.


    OPTION 1: The referenced network from step 1 exists in vCenter.
    You need to update the existing information by resaving vCenter as per below steps:
    1. On the Provider Portal go to Infrastructure Resources -> vCenter Server Instances
    2. Select affected vCenter
    3. Select Edit  and then Save, no need to update any information or add password.


    OPTION 2: The referenced network from step 1 does not exists in vCenter.

    1. Create Network in vCenter with the name from column vc_none_network_name in step 1
    2. Update the existing information by resaving vCenter as per below steps:
        2.1 On the Provider Portal go to Infrastructure Resources -> vCenter Server Instances
        2.2 Select affected vCenter
        2.3 Select Edit  and then Save, no need to update any information or add password.