Error: "No space left on device" occurs during vApp template download
search cancel

Error: "No space left on device" occurs during vApp template download

book

Article ID: 373624

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • A customer is trying to download a vApp template but it is failing.
  • An error like follows is visible:

No space left on device - No space left on device

Environment

Cloud Director 10.x

Cause

This issue occurs if there is not enough space available on the NFS transfer share which is mounted to Cloud Director. During a vApp template download the files are initially staged to the NFS transfer share. If there is not enough space available to accommodate the template then it will fail to download.

To view the space available on the NFS transfer share, run the following command from any Cloud Director cell.

df -h

Resolution

To resolve this matter make additional space available on the NFS transfer share by either removing any old data or alternatively increasing the size of the share on the NFS server.

Alternatively if it's not possible to increase the size of the existing NFS share, consider replacing the existing one with a new larger share as outlined in the documentation Replace the Transfer Server Storage for Your VMware Cloud Director Appliance.