Session timing out in around 15 minutes for vIDM users in remote application.
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Session timing out in around 15 minutes for vIDM users in remote application.

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Article ID: 373580

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Updated On:

Products

VMware NSX Networking

Issue/Introduction

Session timing out in around 15 minutes for vIDM users in remote application.

Environment

NSX
Aria Automation

Cause

Client configuration for the remote application access in Identity manager has access token Time-to-live duration is 15 minutes.

Resolution

Increase Access token Time-To-Live Duration to keep the session alive OR enable refresh token in client configuration.
Note: Take snapshots without memory of all nodes before making any changes.

Steps to increase Access token Time-To-Live Duration.
1) Login to vIDM Ui
2) Navigate to vIDM Admin UI --> Catalog --> Settings --> Remote App Access
3) Find the respective client configuration and edit 
4) Increase the time of access token as required from 15 mins to 10 hours.

OR

Steps to increase Access token Time-To-Live Duration.
1) Login to vIDM Ui
2) Navigate to vIDM Admin UI --> Catalog --> Settings --> Remote App Access
3) Find the respective client configuration and edit 
4) Enable the 'Refresh token' in the respective client configuration which obtains more access token.

Note: When Session Cookie is not used, Application may generate excessive unnecessary login requests to vIDM and cause OAuth2RefreshToken table grow fast and consume huge disk space. Therefore, we recommend disabling refresh token and meanwhile to extend access token TTL from 15 mins to 10 hours.