Unable to see any power supply alarms on Nokia devices
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Unable to see any power supply alarms on Nokia devices

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Article ID: 373465

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Updated On:

Products

VMware Smart Assurance VMware Telco Cloud Service Assurance

Issue/Introduction

Unable to see Power supply and Fan fault alarms on below Nokia devices:

  1. SAR-7705-8 Alcatel
  2. 7250-IXR-TiMOS-B Alcatel
  3. 7750-SR7 Router
  4. SAR-7705-8
  5. 7750-SR 

 Even though the power supply was disconnected/down, there was no alarm generated.

Environment

Smarts v10.1.X

Cause

The OID responsible for Power supply & Fan Monitoring is ".1.3.6.1.4.1.6527.3.1.2.2.1.8.1.16" and we have following possible status on the OID;

tmnxHwOperState   OBJECT-TYPE
    SYNTAX      INTEGER {
                    unknown (1),
                    inService (2),
                    outOfService (3),
                    diagnosing (4),
                    failed (5),
                    booting (6),
                    empty (7),
                    provisioned (8),
                    unprovisioned (9),
                    upgrade (10),
                    downgrade (11),
                    inServiceUpgrade (12),
                    inServiceDowngrade (13),
                    resetPending (14)
                }

In the instrumentation code logic, when the value of the OID (".1.3.6.1.4.1.6527.3.1.2.2.1.8.1.16" ) is 3, the status is mapped to OK, whereas it has to be mapped to CRITICAL.
Hence, there is no alert generated when the power supply is down/disconnected

Resolution

This issue has been fixed TCSA v2.4.0 Smarts Domain Manager Release.
Release Notes: TCSA 2.4.0 Smarts Domain Manager Release Note