NCM Captures fail the majority of the time with ?SPC-OCC-11656: Unable to authenticate with SRAdmin
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NCM Captures fail the majority of the time with ?SPC-OCC-11656: Unable to authenticate with SRAdmin

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Article ID: 37346

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Updated On:

Products

CA Spectrum

Issue/Introduction

When performing NCM Captures on devices that use a custom script, customers may experience “SPC-OCC-11656: Unable to authenticate with SPECTRUM Remote Admin” errors.  If additional manual NCM captures are attempted, it may successfully capture one but will fail the majority of times with the Unable to Authenticate with Spectrum Remote Admin error.

Environment

Spectrum installed on Windows

Cause

1. SRAdmin cache

2.  Windows uses IPV6 Privacy Extensions that cause a temporary IPV6 Ip Address to be created and used.  This can occur even if IPV6 is not being used and IPv4 network address schemes are being used as these temporary IPv6 ip addresses are internal and will not be visible to the operator.

When a script is being used in NCM, SRAdmin will check to see if the connection is a local connection, because these temporary IPv6 addresses are not being shown as localhost the connection will be denied and the error message “SPC-OCC-11656: Unable to authenticate with SPECTRUM Remote Admin” is shown.

Resolution

1.  SRAdmin cache - stop and restart the Spectrum Remote Admin process

2.  IPv6 extensions -

To disable the IPv6 Privacy Extensions open a Windows command shell and type:

netsh interface ipv6 set privacy state=disabled store=active
netsh interface ipv6 set privacy state=disabled store=persistent

These changes are applied immediately and will survive a reboot of the server.