NSX Upgrade fails during pre-check stage due to failure in getting NAPP version
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NSX Upgrade fails during pre-check stage due to failure in getting NAPP version

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Article ID: 373441

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Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention VMware NSX

Issue/Introduction

If NAPP is deployed or upgraded to NSX with a version 4.2.0 or above, NSX upgrade precheck may fail for Edge pre-check stage with below error message:

"Failed to execute Check for NSX Application Platform version for upgrade."

Similar error message is seen on the vCenter when the Pre-Check is run via vLCM.

 

The NSX Upgrade UI will show the following screen

Clicking on the error will shows the error detail

In addition, NSX UI will show the "NSX Application Platform" Tab as "Something is wrong". 

Environment

NAPP 4.2.0

VMware NSX 4.x

Cause

NAPP version is stored in an internal cache during startup. This version should remain persistent until NAPP is upgraded.  However, the upgrade pre-check fails to validate the version due to it missing in the cache. The cache had gotten cleaned up erroneously due to a cron job that runs once a week. 

This impacts only NSX upgrade operation if NAPP 4.2.0+ is installed and upgrade is attempted at least a week after NAPP startup. The version will not be shown in the NAPP UI once the cache has been cleared, but there is no operational impact.

Resolution

Prior to NSX Upgrade or after the upgrade pre-check fails, run the following commands. 

  1. Login to any NSX Manager via SSH using root account
  2. Edit monitor configmap file
    • napp-k edit configmap monitor-application-config -n nsxi-platform
      • The above command will call out a VI styled editor with the NAPP config as content
    • press "i" key for "insert mode"
    • find the value for clearCacheIntervalSeconds value from 604800 to 31449600
    • save the config using :wq!
  3. Restart Monitor pod on all three NSX manager which will reinitialize the cache. 
    • napp-k rollout restart deployment monitor -n nsxi-platform
  4. Run the NSX upgrade precheck again

Note: if you are unable to change the clearCacheIntervalSeconds in the "insert" mode, you can simply run the step 3 but complete your NSX upgrade within 7 days to prevent this issue from occurring. 

Additional Information

VMware by Broadcom will address this issue in the next NAPP release.

Additionally, you may encounter the error when Legacy NSX Intelligence Appliance (VM-based) are present in the environment. In that case follow the steps on kb:

NSX Upgrade Pre-check fails with the error message "Failed to execute Check for NSX Application Platform version for upgrade."