"404 OK" when Applying Day 2 Action From Service Broker
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Article ID: 373393
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Updated On:
Products
VMware Aria Suite
Issue/Introduction
When a user tries to run Day 2 Actions against a resource in vRA Service Broker such as a Virtual Machine, they are faced with error "404 OK" as shown below:
We also see errors in /services-logs/prelude/identity-service-app/file-logs/identity-service-app.log:
identity-service-app.log.:202#-##-##T##:##:##.###Z ERROR identity-service [host='identity-service-app-#####' thread=#####' user='#####' org='#####' trace='#####'] c.v.i.c.RestResponseEntityExceptionHandler.logError:### - Handling response status exception: 404 NOT_FOUND "New access and refresh tokens cannot be obtained with the provided subject_token."
Environment
VMware Aria Automation 8.17.0, 8.18.0
Cause
This issue occurs with certain versions of Aria Automation
Resolution
Workaround
Assign "Assembler User" or higher privileges to the user.
Access Day 2 Actions from Deployments rather than directly from the VM list as shown below