Rally: why i am not able to see custom fields in Rally
search cancel

Rally: why i am not able to see custom fields in Rally

book

Article ID: 373386

calendar_today

Updated On:

Products

Rally SaaS

Issue/Introduction

As a Rally Project admin user, I’m unable to locate the custom field named ‘XXXXXXXX’ in my project. Despite setting the visibility to true, the custom field remains inaccessible in my Rally pages.

Here are the field details:

  • Field Type: Iteration
  • Field Name: XXXXXXXXXX
  • Field Attribute Type: Drop Down list

 

Environment

Rally SAAS

Cause

Administrators(subscription/Workspace/Project) typically manage custom field visibility based on where the field is created. If you want only specific projects to access a new field, create it from a particular project or at the top of the project hierarchy you intend to use. Conversely, if you want to hide a new field from certain projects, create it at the workspace level and then set it to be hidden in those specific projects

Resolution

To address this issue, user should set the project hierarchy to "Child" Projects and exclude the parent hierarchy checkbox where the custom field ‘XXXXXXXX’ does not exist. 

Additional Information

  • Use the Visibility in Teams field to control which projects have access to use the field. Fields that are visible in a project are available in:
    • Work item detail editor
    • Rally pages
    • Apps
    • Notification Rules
    • Web Services API
  • Visibility in Project field helps to set the field to be visible to all projects or to none in the project/workspace.
  • You cannot delete a field after it has been created. You can only hide it from view.
  • Custom fields are not supported in timesheets & Reports