vSphere Lifecycle Manager Options Greyed Out After Upgrading vCenter Server
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vSphere Lifecycle Manager Options Greyed Out After Upgrading vCenter Server

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Article ID: 373331

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

After upgrading vCenter Server to a newer version, users may find that vSphere Lifecycle Manager (vLCM) options are greyed out and unusable in the vSphere Client interface. This prevents administrators from using vLCM to patch and update hosts, potentially impacting system security and performance.

Environment

- vCenter Server upgraded to a newer version
- Issue observed after the upgrade process

Cause

The issue may occur due to incomplete or corrupted installation of vLCM components during the upgrade process. Specifically, there might be problems with the extension registration or missing files for the Lifecycle Manager client extension.

Resolution

Follow these steps to resolve the issue:

1. Access the Managed Object Browser (MOB) for your vCenter Server:
   a. Open a web browser and navigate to: https://[vCenter_Server_FQDN_or_IP]/mob
   b. Log in using your vCenter Server administrator credentials.
   c. If you receive a certificate warning, proceed after verifying you're connecting to the correct server.

2. In the MOB, navigate to:
   content > extensionManager > UnregisterExtension

3. In the Value field, enter: com.vmware.vcIntegrity

4. Click Invoke Method to unregister the extension.

5. Locate a known working vCenter Server of the same version as your upgraded system. If you don't have one available, contact VMware for help.

6. On the working system, navigate to: /etc/vmware/vsphere-ui/cm-service-packages/com.vmware.cis.vsphereclient.plugin/

7. Copy the com.vmware.vum.client-[version] folder from the working system. The [version] will match your current vCenter Server version.

8. On the affected vCenter Server, paste the copied folder to the same location, overwriting existing files if prompted.

9. Set the ownership of the copied files and folders to vsphere-ui:

   chown -R vsphere-ui:vsphere-ui /etc/vmware/vsphere-ui/cm-service-packages/com.vmware.cis.vsphereclient.plugin/com.vmware.vum.client-[version]

10. Stop the VMware Update Manager service:

   service-control --stop vmware-updatemgr

11. Stop the vSphere UI service:

    service-control --stop vsphere-ui

12. Start the vSphere UI service:

    service-control --start vsphere-ui

13. Start the VMware Update Manager service:

    service-control --start vmware-updatemgr

14. Log in to the vSphere Client and verify that the vLCM options are now available and functioning correctly.

Additional Information

  • If you encounter any issues during this process, consider taking a backup of the affected folders before making changes.
  • For more information on using the Managed Object Browser, refer to the VMware documentation on vSphere MOB.
  •  Managed Object Browser
  • This solution may apply to various upgrade scenarios. If the issue persists, contact VMware support for further assistance.