Updating the NotificationData value for a SANMFilter using CLI does not reflect in AlarmNotifier.
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Updating the NotificationData value for a SANMFilter using CLI does not reflect in AlarmNotifier.

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Article ID: 373326

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Updated On:

Products

DX NetOps CA Spectrum

Issue/Introduction

We need to change the Notification Data e-mail address for our SANM Filters. We have a very large number of SANMFilter models so to do this manually would be very time consuming.

We developed a Command Line Interface (CLI) script that finds all of the SANMFilter models and updates the NotificationData attribute id 0xd7000b for each SANMFilter model to the new e-mail address.

However, after doing this, AlrmNotifier is still using the old e-mail address for new alarms and not the new e-mail address.

Environment

Version: Any
Component: Application / AlarmNotifier / Spectrum Alarm Notification Manager (SANM)

Cause

When modifying the Notification Data field using OneClick, all values for the filter are reread. 

When updating the NotificationData attribute id 0xd7000b using CLI, this does not trigger a reread of all the values for the filter.

Resolution

The resolution is to do one of the following:

  • Restart the AlarmNotifier process.
  • Use CLI to create event 0xd70008 on the SANMPolicy model associated with the SANMFilter model

For example:

./create event type=0xd70008 text="ManualChange" mh=0x100006e
Date       Time       Type        MHandle     MName             MTypeName
07/29/2024 12:20:54   0xd70008    0x100006e   DefaultPolicy     SANMPolicy

The 0xd70008 is the event that is generated when a policy has been modified. This triggers a reread of all the values for all of the Filters associated with the SANMPolicy model.

NOTE: This will not update the NotificationDate for any existing alarms that are either updated or cleared. They will still use the original e-mail address from when the alarm was set.