Data Services UI (Version & Upgrade > Data Services view) is stuck on a loading screen post upgrade to 2.1
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Data Services UI (Version & Upgrade > Data Services view) is stuck on a loading screen post upgrade to 2.1

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Article ID: 373289

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Updated On:

Products

VMware Data Services Manager

Issue/Introduction

Symptoms:

Data Services view under Version & Upgrade in DSM is unable to load after upgrade to version 2.1

Environment

VCF and Data Services Manager (DSM) 2.1

Cause

This issue is caused by network interruption between AWS and DSM while bundle is being downloaded from provider repository.

Resolution

1. ssh to the Data Services Manager Appliance

2. Extract the bearer token by running the following command:

curl -k -v -location 'https:/<provider_ip>/provider/session' --header 'Content-Type: application/json' --data-raw '{ "email" : "[email protected]", "password" : "YourPassword!@123" }'

Note: replace email and password 

3. Execute the following command to copy files from S3 to the local Appliance:

curl -k -v --location --request POST 'https://<PROVIDER_IP_ADDRESS>/updatemanager/copy-bundles' \
--header 'Authorization: Bearer <BEARER TOKEN>' \
--header 'Accept: application/json, text/plain, */*'

Note: this copy process can take up to 1-2 hours to complete.