eHealth alarmForwarder does not work on Linux 6.5

book

Article ID: 37324

calendar_today

Updated On:

Products

EHEALTH CA eHealth

Issue/Introduction

Problem:
Alarm forwarder does not work on Linux 6.5. After all integration steps I got the error message:

Can't load '/export/bycvi01-sem/ehealth/custom/alarmForwarder/linux/auto/Crypt/SSLeay/SSLeay.so' for module Crypt::SSLeay: libssl.so.6: cannot open shared object file: No such file or directory at /export/bycvi01-sem/ehealth/perl/lib/DynaLoader.pm line 190.
at /export/bycvi01-sem/ehealth/custom/alarmForwarder/lib/REST/Client.pm line 82
Compilation failed in require at /export/bycvi01-sem/ehealth/custom/alarmForwarder/lib/REST/Client.pm line 82.
BEGIN failed--compilation aborted at /export/bycvi01-sem/ehealth/custom/alarmForwarder/lib/REST/Client.pm line 82.
Compilation failed in require at ./alarmForwarder.pl line 15.
BEGIN failed--compilation aborted at ./alarmForwarder.pl line 15.
 
 
Environment:
eHealth 6.3.2.05 installed on Linux 6.5 Operating system. 

 
Cause:
An installed package openssl098e-0.9.8e-17.el6_2.2.i686 is required to run alarmForwarder, which is missing in this case.
 
 
Resolution:
This problem has been addressed via Defect ticket 329337 and fixed in eHealth release 6.3.2.07.
 
As a workaround, it can be resolved by installing the package openssl-1.0.1e-15.el6.i686 (#yum install openssl.i686).
 
 
Additional Information:
In some cases, there is problem with running perl also, and that can be solved by changing perl directory path from $NH_HOME to /opt/ehealth in AlarmForwarder.sh file

Environment

Release:
Component: EHSPEC