Maileater does not process emails from unknown senders after an upgrade
search cancel

Maileater does not process emails from unknown senders after an upgrade

book

Article ID: 373230

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

An unknown sender (ie: integration email account) sends an email to the maileater mailbox with the %FROM_EMAIL_OVERRIDE value associated to an SDM contact with permissions to create a ticket.

After upgrading to SDM 17.3 RU18 and later/17.4 GA and later, maileater won't process emails from unknown senders and tickets won't be created. In previous versions, the ticket was created.

Environment

SDM 17.3 RU18 and later

SDM 17.4 GA and later

Cause

A code change has been introduced in 17.3 RU18 which was carried forward to 17.4 GA code. Due to this change, you see a change in the behavior comparing with previous SDM versions

Resolution

This is expected behavior due to the code change mentioned above.

 

For maileater to continue reading the Unknown Emails (previous behavior), the following workaround is available:

1. Run the following commands in CMD:

pdm_options_mgr -b -c -s DONOT_ENFORCE_SECURITY_ON_UNKNOWN_MAILS -v Yes -a pdm_option.inst

pdm_options_mgr -b -c -s DONOT_ENFORCE_SECURITY_ON_UNKNOWN_MAILS -v Yes -a pdm_option.inst -t

2. Restart the SDM service for changes to take effect.

 

This new "DONOT_ENFORCE_SECURITY_ON_UNKNOWN_MAILS" option allows SDM to keep the previous behavior and read unknown emails.

Additional Information

More details about the option are in the 17.4 RU1 steps to reproduce under Defect ID DE574567