Classic: Allocation Costs not updating
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Classic: Allocation Costs not updating

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Article ID: 373193

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

In Classic Clarity if the allocations are removed by resetting the default allocations on the properties,  the allocation cost will not be removed after running Update Cost Totals.  If the resource is hard booked, the hard booked allocation cost is removed, but not the field for allocation cost.  This field is populated into data warehouse and in this scenario, there will be 0 allocation but an allocation cost.

STR:

1.  In Classic allocate a resource to a project.

  - Make sure the resource is financially enabled

  - Make sure the project is associated to a rate matrix

  

2.  Make sure the resource's default allocation > 0 (so they get allocation)

3.  Run full rate matrix extraction job so the costs are associated to the resource   

4.  Run Update Cost Totals on the team page or staff detail page for the resource. Or run the job Update Earned Value and Cost Totals

5.  If the Allocation Cost field is not on your team list page add it.  There should now be a cost for this resource

6.  Open the properties for the resource on the team and set the default allocation to 0 to remove the allocations.

    - Return to the team list or staff details page. 

7.  Run Update Cost Totals again for the resource

    - Note you may receive an error on this page with Object not found.  

         

           If the Error occurs you will need to navigate to another page and then back and run  Update Cost Totals again.

 

Expected Results:   Allocation Costs are reset to 0

Actual Results:  Allocation Costs remain.  If the resource is hard booked, the hard booked allocation costs are removed, but the normal allocation costs remain.

Workaround:  Edit the TSV to add a value, save, then enter 0.  This creates a segment in the allocation details which is then recognized by the job to update the costs.

 

Because Allocation Cost is only shown in Classic, MUX is not affected.  

         

Environment

16.1.3 through 16.2.3

Classic Clarity only.

Cause

This only happens when there are no segments identified in the Allocation portion of the Staff Member Properties.

The properties will only have one line and that line will have no calendar options on it.

By using the Workaround and adding a value to the TSV, saving, and then resetting the entry to 0,  will then create  the segments as shown below.

Once you have segments like this, then Update Cost Totals will reset the allocation cost to 0.

Resolution

Reported as DE116358

Currently under review.