How to configure Protection Engine Console to manage a server whose REST API service is using a port number outside the range of 1025-65536.
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How to configure Protection Engine Console to manage a server whose REST API service is using a port number outside the range of 1025-65536.

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Article ID: 373184

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Updated On:

Products

Protection Engine for Cloud Services

Issue/Introduction

The Protection Engine REST API service, by default, listens on port 8008, but is configurable to listen on any available port. However, when an attempt to add a server to be managed via the SPE Console for Windows, it will only accept port values 1025 - 65536

Environment

Protection Engine 9.x

Cause

The console program was coded with an arbitrary range of ports that were likely to not be in use.

Resolution

Broadcom Engineering is aware of this issue and is committed to providing a fix.

For a temporary resolution please see the simple workaround as follows.

Workaround:

The workaround assumes that the server side has already been configured for the desired port e.g: 443, by editing the application.properties file, changing the "server.port=" and restarting the Rest API service.

Standard Authentication:

  1. Create a .csv file on the local computer.

  2. Enter the required information in the following format:    ServerName,443,Administrator,Password@12345,false      {the last value is for whether to use SSL or not}

  3. Open the Console, and open the dialogue to add a new server.
  4. Click the box at the bottom "Import CSV" and browse for the previously created file.  The console will accept the input parameters and attempt to contact the server via the specified port. If the server is listening on the port and reachable the connection should complete.

 

AD Authentication:  

Use the same steps as Standard Authentication except the CSV needs to be in the following format:   server-name-or-address, port, UseSSL

Example:   ServerName,443,false