MTU Validation error on ESXi host after upgrade or when configuring NSX
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MTU Validation error on ESXi host after upgrade or when configuring NSX

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Article ID: 373135

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Updated On:

Products

VMware NSX VMware NSX-T Data Center

Issue/Introduction

This issue is observed in two different ways as follows:

1. After performing an upgrade of NSX to version 4.2.3.0:

  • Immediately after an upgrade of NSX to version 4.2.3.0, the following error is observed on all upgraded ESXi hosts under the System -> Fabric -> Hosts tab of the NSX UI:
    9531: VDS [<name>] does not need field MTU to be specified in its uplink profile [BaseHostSwitchProfile/<UUID>]. Keep the field MTU in uplink profile for a VDS switch empty. Field MTU for VDS has to updated from vSphere. (Error code: 9531)
  • SDDC Manager is in use and this uplink profile was SDDC created
  • Screenshot of this tab:


2. While configuring NSX on a cluster as follows:

  • When attempting to configure a host as a transport node, it fails with:
    Error: VDS [<name>] does not need field MTU to be specified in its uplink profile [BaseHostSwitchProfile/<UUID>]. Keep the field MTU in uplink profile for a VDS switch empty. Field MTU for VDS has to updated from vSphere. (Error code: 9531)
  • Review of Uplink Profiles in use shows MTU setting other than "1700 (Global MTU)", the default value displayed when the profile's MTU field is left blank. The example below from a generic lab environment shows an uplink profile with an MTU configured to a custom value.

Environment

VMware NSX 4.x
VMware NSX-T Data Center 3.x

Cause

Prechecks when attempting to add a node to a cluster will fail if an uplink profile has an MTU setting that is not consistent with the Virtual Distributed Switch the host will connect to.
Refer to Configuring a vSphere Distributed Switch which states: "As a host transport node that is prepared using VDS as the host switch, the MTU value needs to be set on the VDS switch in vCenter Server."
MTU specification, other than default by leaving the field blank, is still an option to set with an Uplink Profile when the nodes to which it will be assigned will not be on a Virtual Distributed Switch.

Resolution

At System > Configuration > Fabric > Profiles, select and edit the applicable Uplink Profile, then delete the MTU value at the bottom of the window to leave it blank, then click Save.

 

If editing the profile is not permitted over being in use by Transport Nodes, this results in an error such as:

The uplink host switch profile is referenced by 4 Transport Node(s). The MTU for VDC switches should not be specified in NSX. Please update the MTU in vCenter. (Error code:8548)

In this case you can work around this limitation by duplicating the existing uplink profile into a copy, unset the MTU value in this copy, and either assign this copy profile manually (via the action Configure for NSX) to the Transport Node hosts, or into the Cluster's Transport Node Profile directly if the cluster binds a TPN. This will free the original uplink profile for edition, in case you need to retain this profile if it was provisioned from an external solution managing the cluster, such as VCF: once the MTU value is unset you can reassign this corrected, original uplink profile back onto the hosts and delete the copy profile.

Once the uplink profile does not list a MTU value anymore, you can run the normal process for Preparing ESXi Hosts as Transport Nodes and it should no longer fail the precheck.

Additional Information

 Create an Uplink Profile explains all the various settings in an uplink profile that can be applied to a Transport Node by selecting as part of a Transport Node Profile attached to a host or a cluster of hosts configured as transport nodes in NSX Manager. 

Also see Guidance to Set Maximum Transmission Unit with other helpful information.

If you are contacting Broadcom support about this issue, please provide the following:

  • vCenter Server and ESXi host log bundles for the affected cluster
  • Ensure log date range covers the full date of the event(s) being investigated. When in doubt, retrieve logs for all time.
  • NSX Manager log bundles
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation

Handling Log Bundles for offline review with Broadcom support