Error obtaining ODBC handle or Native Diagnostic: 08S01:0 [CA SSO][ODBC 20101 driver]7503
search cancel

Error obtaining ODBC handle or Native Diagnostic: 08S01:0 [CA SSO][ODBC 20101 driver]7503

book

Article ID: 373133

calendar_today

Updated On:

Products

SITEMINDER CA BCS Premier for CA Single Sign-On CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign-On

Issue/Introduction

12.8SP7 server repeatedly shows error like below in smps.log, and sometimes it says the connection recovered.

The error appears in interval timing between 5 minutes, 30 minutes, 2 hours, etc.

[1204347/139751097894656][Thu MM dd yyyy 11:04:21.515][HSTMT.cpp:245][Error][ERROR][sm-xpsxps-00800] While calling "SQLConnect(Example SiteMinder Data Source)", the following error occurred:
[1204347/139751097894656][Thu MM dd yyyy 11:04:21.515][HSTMT.cpp:259][Error][ERROR][sm-xpsxps-00810] Native Diagnostic: 08S01:0 [CA SSO][ODBC 20101 driver]7503
[1204347/139751097894656][Thu MM dd yyyy 11:04:21.515][HSTMT.cpp:259][Error][ERROR][sm-xpsxps-00810] Native Diagnostic: 21:-4 [CA SSO][ODBC 20101 driver][20101]10703
[1204347/139751097894656][Thu MM dd yyyy 11:04:21.515][XPSODBC.cpp:839][CXPSIOODBC][ERROR][sm-xpsxps-00960] Error obtaining ODBC handle.
[1204347/139751097894656][Thu MM dd yyyy 11:09:21.542][HSTMT.cpp:245][Error][ERROR][sm-xpsxps-00800] While calling "SQLConnect(Example SiteMinder Data Source)", the following error occurred:
[1204347/139751097894656][Thu MM dd yyyy 11:09:21.542][XPSODBC.cpp:839][CXPSIOODBC][ERROR][sm-xpsxps-00960] Error obtaining ODBC handle.
[1204347/139751097894656][Thu MM dd yyyy 11:14:21.991][Housekeeping.cpp:800][HouseKeeping][INFO][sm-xpsxps-00660] Recovered server connection.

....

[177240/139625020450560][Thu MM dd yyyy 18:07:33.003][XPSODBC.cpp:839][CXPSIOODBC][ERROR][sm-xpsxps-00960] Error obtaining ODBC handle.
[177240/139625020450560][Thu MM dd yyyy 18:07:33.002][HSTMT.cpp:259][Error][ERROR][sm-xpsxps-00810] Native Diagnostic: 21:-1 [CA SSO][ODBC 20101 driver][20101]13116
[177240/139625020450560][Thu MM dd yyyy 18:07:33.003][XPSODBC.cpp:839][CXPSIOODBC][ERROR][sm-xpsxps-00960] Error obtaining ODBC handle.

....

[177240/139625020450560][Thu MM dd yyyy 18:48:18.184][HSTMT.cpp:259][Error][ERROR][sm-xpsxps-00810] Native Diagnostic: 08001:0 [CA SSO][ODBC 20101 driver]7505
[177240/139625020450560][Thu MM dd yyyy 18:48:18.184][HSTMT.cpp:259][Error][ERROR][sm-xpsxps-00810] Native Diagnostic: 21:-1 [CA SSO][ODBC 20101 driver][20101]11603
[177240/139625020450560][Thu MM dd yyyy 18:48:18.185][XPSODBC.cpp:839][CXPSIOODBC][ERROR][sm-xpsxps-00960] Error obtaining ODBC handle.

Environment

Policy server: 12.8SP7

Policy Store: Oracle Database 19c

Cause

Several possible causes:

  • Native Diagnostic: 08S01 often points to a TCP/IP network failure.  Communication link failure is a mid-stream failure of the connection from client to DB Server. This typically points to problems with networking layer, possibly networking hardware. For example, a router in the network could be dropping connections, or a network card that is going bad.
  • Firewall blocks or disconnects socket connection between policy server and Database.
  • Connection between policy server and Database was in idle and had passed max timeout value setting at OS level.
  • Database Server has performance issue, not always accept connections.

Resolution

DB connection interval timing between 5 minutes, 30 minutes, 2 hours is by design. These DB connections will sleep for a while and then wake up.

  • Identified the TCP Keep-Alive OS settings on policy server and the default value should be 2 hours.

/proc/sys/net/ipv4/tcp_keepalive_time=7200

  • Inside system_odbc.ini,  add a parameter called "KeepAlive=1", then recycle policy server.
[Example SiteMinder Data Source]
...
ApplicationUsingThreads=1
DMCleanup=2
EnableTimestampWithTimeZone=1
EnableNcharSupport=0
KeepAlive=1
 
  • Ask network team to check router performance and increase firewall idle timeout value settings.

  • Ask DBA to check Database performance or increase the max process limit on Oracle DB.   This resolved the issue in the end.

Additional Information

Snoop or SnoopOracle packet logging tool, which is diagnosis tool provided by Progress DataDirect.
This Java-based utility is used to log network packets between a database and driver.

https://community.progress.com/s/article/3368