"Login error" seen when trying to run a configuration capture in Spectrum OneClick
search cancel

"Login error" seen when trying to run a configuration capture in Spectrum OneClick

book

Article ID: 373122

calendar_today

Updated On:

Products

DX NetOps CA Spectrum

Issue/Introduction

When running a configuration capture for a device using the Network Configuration Manager (NCM) in Spectrum OneClick, we are seeing the following error:

This is seen using our production Spectrum installation.

This is not seen in our test Spectrum environment.

Both environments are using the same exact NCM configuration setting and script.

Environment

Version: Any
Component: Application / Network Configuration Manager / (NCM)

Cause

The following error is seen when trying to ssh to the device from the production SpectroSERVER system run as the user that owns the Spectrum installation:

Can't open user config file /etc/sh/ssh_config.d/legacy.conf

Permissions on the file are -rw-r-----  1  root root

When ssh is run as the root user, it is successful with no error.

On the test SpectroSERVER system where it works, the permissions for that file are rw-r--r---

Resolution

Change permissions to rw-r--r--- on the file on the production SpectroSERVER system.