Duplicate VNI encountered with Logical Switches in VMware NSX
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Duplicate VNI encountered with Logical Switches in VMware NSX

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Article ID: 373063

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Updated On:

Products

VMware NSX VMware NSX-T Data Center

Issue/Introduction

  • Logical switches created in NSX may be assigned a VNI (VXLAN network Identifier) of an existing segment, resulting in duplicate VNI(s) in the system.
  • Realization of a new Logical Switch on an Edge Transport Node may fail.
  • A VNI ID is associated with a Logical Switch, but the same VNI ID is still available in the VNI pool.
  • Logical Switches with the same VNI ID can be observed in output of "get logical-switches" run on NSX Manager:
    • In admin mode:
      get logical-switches


    • In root mode:

      # su admin -c get logical-switches | grep -v "^$\|VNI" | awk '{print $1, $3}' | sort | uniq -w 6 -c | sort -r | head -n 5

      Note: line count in "head -n 5" can be increased to display more lines.

Environment

VMware NSX 4.x.
VMware NSX-T Data Center 3.x.

Cause

An update or delete of a Logical Switch (LS) done on the Management Plane is handled concurrently by two different Manager nodes.
As a part of the delete activity, the NSX Manager releases the VNI, but an update operation which is triggered a few milliseconds later prevents the deletion of that Logical Switch / VNI from the NSX Manager's Corfu DB.

Due to this, the NSX Manager may have stale VNI entries for VNIs which are already associated with a Logical Switch, but at the same time, these VNIs are also available for consumption (to be assigned) in the VNI pool, which creates a possibility where a free VNI may be picked from the pool and assigned to a new Logical Switch.

The fix for this issue is to ensure that only one NSX Management node handles CRUD operations for a Segment


Resolution

This issue is resolved in VMware NSX 4.1.1, 4.2.0 and VMware NSX-T Data Center 3.2.4, available at Broadcom downloads.

An upgrade will not resolve already impacted VNIs, the upgrade will carry over duplicate VNIs, any existing duplicates will need to be cleaned up manually by Broadcom Support. 

 

If you suspect the presence of duplicate VNIs in your environment, please contact Broadcom Support and reference this KB article.