Error "The credentials were incorrect or the account specified has been locked., error code 403" when performing any task on the VM in VMware Cloud Director
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Error "The credentials were incorrect or the account specified has been locked., error code 403" when performing any task on the VM in VMware Cloud Director

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Article ID: 373033

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Unable to perform any task on the VM including power on/off

You will get a generic error message in the vCD UI: The entity Test-vApp is in an invalid state for operation poweroff.

  • From /opt/vmware/vcloud-director/logs/vcloud-container-debug.log,  you will notice an error similar to below:

The entity Test-vApp is in an invalid state for operation poweroff.
com.vmware.ssdc.util.LMException: Forbidden: Error occurred in the backing network provider: The credentials were incorrect or the account specified has been locked., error code 403

Environment

VMware Cloud Director 10.x

Cause

This issue can occur if the password for a registered NSX Manager instance has been changed

Resolution

Edit the integrated NSX Manager Settings in VMware Cloud Director Provider portal and update the password using below steps:

  1. From the top navigation bar of the provider portal, under Resources, click Infrastructure Resources.
  2. In the left pane, click NSX-T Managers and click the name of the NSX Manager instance that you want to modify.
  3. In the upper right corner of the General tab, click Edit.
  4. Edit the NSX Manager settings and update the password.
  5. Click Save.

Additional Information

For more information on how modify the NSX Manager settings in VMware Cloud Director, click here