Error: "The credentials were incorrect or the account specified has been locked., error code 403" when performing tasks on VMs and Edges
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Error: "The credentials were incorrect or the account specified has been locked., error code 403" when performing tasks on VMs and Edges

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Article ID: 373033

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Unable to perform any task on the VM including power on/off.
  • You will get a generic error message in the Cloud Director(VCD) UI:

    The entity <vapp-name> is in an invalid state for operation poweroff.
  • On the Cloud Director cell within the log file /opt/vmware/vcloud-director/logs/vcloud-container-debug.log  you will notice an error similar to below:

The entity <vapp-name> is in an invalid state for operation poweroff.
com.vmware.ssdc.util.LMException: Forbidden: Error occurred in the backing network provider: The credentials were incorrect or the account specified has been locked., error code 403

  • "Error: [ ######## ] Forbidden: Error occurred in the backing network provider: The credentials were incorrect or the account specified has been locked., error code 403" is encountered while trying to select the Edge Gateway in VMware Cloud Director UI.

  • vCloud director unable to create any firewall rules on edge gateway.

Environment

VMware Cloud Director 10.6.x

Cause

This issue will occur if the password for a registered NSX Manager instance has been changed.

Resolution

To resolve this issue edit the integrated NSX Manager settings in the VMware Cloud Director Provider portal and update the password using below steps:

  1. Login to the Cloud Director provider portal.
  2. From the left navigation bar of the provider portal select "Resources > Infrastructure Resources".
  3. Navigate to "NSX-T > NSX-T Managers".
  4. Click the name of the NSX Manager instance that you want to modify.
  5. On the General tab, click "Edit".
  6. Review the NSX-T Manager username and type the updated NSX-T password into the password textbox.
  7. Click Save.

Note: It's recommended to confirm the NSX-T username / password are working by opening the NSX-T Manager UI and logging in with the username/password directly. 

Additional Information