Could not allocate a new page for database 'TEMPDB' because of insufficient disk space in filegroup 'DEFAULT' while running an export from Client Tools
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Could not allocate a new page for database 'TEMPDB' because of insufficient disk space in filegroup 'DEFAULT' while running an export from Client Tools

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Article ID: 372989

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Updated On:

Products

CA Identity Governance CA Identity Suite

Issue/Introduction

While running an export from Client Tools the following message can be displayed in the Identity Governance log file:

Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: Could not allocate a new page for database 'TEMPDB' because of insufficient disk space in filegroup 'DEFAULT'. Create the necessary space by dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.

Environment

Identity Governance 14.x

Cause

This is caused due to tempdb being used for the export that stores the data in the database

Resolution

To resolve this issue, adjust your auto-growth settings for the database:
 
  1. Log in to SQL Server Management Studio with a user having sysadmin privileges.
  2. Expand System Databases, right-click the tempdb and click on Properties.
  3. Click Files in the left pane and then click on the ellipses button.
  4. In the Change Autogrowth window ensure Enable Autogrowth is selected, and change File Growth section to In Percent and select 10. Ensure the Maximum File Size field is set to unrestricted File Growth.
  5. After clicking OK, the new settings should be set.
  6. Run a new export from Client Tools.