Configurator page throws "Blank red box error" in VMware Identity Manager
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Configurator page throws "Blank red box error" in VMware Identity Manager

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Article ID: 372880

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When accessing the URL <https://<vIDM-FQDN>:8443/cfg/> configurator page displays "Blank red box" 

We also observe 'An unexpected error has occurred. Please try again later' on the Health Diagnostic Dashboard page in the Admin Console.

Environment

VMware Identity Manager 3.3.x

Cause

The issue was attributed to one of the following factors:

  • Incorrect permission or ownership of VMware Identity Manager configuration files and directories.
  • A database lock hindering the proper initialization of VMware Identity Manager services.

Resolution

To resolve this issue, please follow these steps:

  • Ensure you have a snapshot of the vIDM appliance before proceeding.
  • Issue a remediate request against the globalenvironment in Aria Suite Lifecycle Manager if the vIDM environment is not reporting as healthy
  • Validate the permissions and ownership of files under the 'conf' folder by following the steps outlined in KB article 89301.
  • Check for any database locks as described in KB articles 319309 and 370272.

 

If the issue persists after validating permissions and checking for database locks, proceed with the following steps:

  • Validate the configuration in config-admin.json, idm-cacerts and system-config.properties files located in /usr/local/horizon/conf/.



  • Use the ls -l command to check if these files are corrupted or have a size of 0KB.

  • If corrupted or empty, copy the content from a working node to the corrupted node.

  • Validate the permission and ownership on "<WORKER_ID>" folder under "/usr/local/horizon/conf/states/<TENANT_NAME>/" as given below:



    If the "<WORKER_ID>" folder hold different permission or ownership execute the below command:
    cd /usr/local/horizon/conf/states/<TENANT_NAME>/
    
    chmod 750 <WORKER_ID>
    
    chown horizon:www <WORKER_ID>

     

  • Restart the HZN (Horizon) service by running the command:
    service horizon-workspace restart

These steps should help in resolving the issue you are facing with the vIDM configurator page