Vmware NSX Native Load Balancer pool members with a status of "down" do not display a "Failure Reason"
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Vmware NSX Native Load Balancer pool members with a status of "down" do not display a "Failure Reason"

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Article ID: 372869

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Updated On:

Products

VMware NSX

Issue/Introduction

  • VMware NSX Native Load Balancer (LB) Pool has one active monitor configured.
  • A pool member is DOWN, but the NSX UI does not display the "Failure-Reason".
  • The API does not return  "Failure-Reason" either:
    • GET https://<NSX Manager>/api/v1/loadbalancer/services/<UUID/status?source=realtime
  • Running the following command as admin user in the edge Cli does return a "Failure-Reason":
    • get load-balancer <UUID> pool <UUID> status
      ...
      Monitor

      Display-Name : LB_Http_Monitor
      Type : HTTP
      Status : down
      Url : /
      Last-Check-Time : <date/time>
      Last-State-Change-Time : <date/time>
      Failure-Reason : Connect to Peer Failure
      ...

Environment

VMware NSX 3.1.x, 3.2.x

Cause

This issue occurs due to a mismatch with LB monitor index.

Resolution

To workaround, there are 2 options:

Option 1: Use the Edge Cli to obtain the failure reason (get load-balancer <UUID> pool <UUID> status)
Option 2: Configure a second active monitor on the pool. The second active monitor can be of any type ICMP/TCP/HTTP. 

Issue is resolved in VMware NSX 3.1.3.6 and 3.2.1.