Startup fails with ClassNotFound error after installation on WebSphere Application Server (WAS)
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Startup fails with ClassNotFound error after installation on WebSphere Application Server (WAS)

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Article ID: 372858

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Updated On:

Products

CA Identity Manager

Issue/Introduction

After installing Identity Manager on WAS (WebSphere Application Server), the startup fails with ClassNotFound or ClassDefNot found errors.

************* End Display Current Environment *************
[7/19/24 18:23:48:122 GMT] 00000109 webapp        E com.ibm.ws.webcontainer.webapp.WebApp logServletError SRVE0293E: [Servlet Error]-[com.ibm.ws.webcontainer.extension.DefaultExtensionProcessor]: java.lang.ClassNotFoundException: com.netegrity.ims.manage.filter.LocaleFilter
        at java.lang.Class.forNameImpl(Native Method)

Environment

WebSphere 8.x

Cause

The dmgr and node_manager logs report that the EAR file cannot be expanded due to a lack of disk/file space. Checking the log activity before the ClassNotFound errors show errors similar to those below, indicating lack of file space.

[7/22/24 15:57:55:867 GMT] 000045b5 AddBinaryTask E   ADMA7101E: An unexpected error occurred for the EAR expansion process. The enterprise archive (EAR) file iam_im is not extracted in the following paths /test/apps/sampleidmcl00/sampleidmcl-n01/installedApps/sampleidmcl-c01/iam_im.ear. On node: sampleidmcl-n01
[7/22/24 15:57:55:869 GMT] 000045b5 FileDocument  E   ADMR0104E: The system is unable to read document /test/apps/sampleidmcl00/sampleidmcl-n01/config/temp/download/cells/sampleidmcl-c01/nodes/sampleidmcl-n01/node.xml: java.io.IOException: No space left on device
    at java.io.File.createTempFile(File.java:2074)
    at com.ibm.ws.management.repository.FileDocument.createTempFile(FileDocument.java:657)
    at com.ibm.ws.management.repository.FileDocument.read(FileDocument.java:585)..

Based on the messages above, the managed server will not start and throws ClassNotFound errors, because the iam_ear was not extracted and is not available for deployment due to a lack of disk space.

Resolution

Free up space on the disk, or increase disk size. For further assistance contact your WebSphere Adminstrator.