HCX - Unable to upgrade with the error: "JSONObject["applianceType"] not found"
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HCX - Unable to upgrade with the error: "JSONObject["applianceType"] not found"

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Article ID: 372833

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Updated On:

Products

VMware HCX

Issue/Introduction

  • The following error is observed in /common/logs/admin/app.log:
2024-07-02 10:01:35.058 UTC [EventingService_SvcThread-18, Ent: HybridityAdmin, , TxId: ######-####-####-####-############] ERROR c.v.v.h.s.e.j.QueueHcxEventsOnRemote- Error starting QueueHcxEventsOnRemote job
org.codehaus.jettison.json.JSONException: JSONObject["applianceType"] not found.
  • The download progress remains at 0% and does not progress on the UI.
  • There are no connectivity issues with connect.hcx.vmware.com or hybridity-depot.vmware.com.

Environment

HCX

Cause

A stale entry in the HCX database.

Resolution

None at the moment.


Workaround:
Open a Service Request with VMware by Broadcom Global Support Services.

Additional Information

As a temporary workaround, perform the upgrade using the offline bundle method. 

Upgrade HCX Manager for Local Sites