An existing connection was forcibly closed by the remote host OM Web Viewer 12.1
search cancel

An existing connection was forcibly closed by the remote host OM Web Viewer 12.1

book

Article ID: 372795

calendar_today

Updated On:

Products

Output Management Web Viewer

Issue/Introduction

Having issues when trying to connect and interact with Web Viewer such as downloading reports from Web Viewer.

Example error is below:

ERROR: CCIClient [https-openssl-nio2-port-exec-8] ## Error in recvTcpPacket- error PRC:(CCIUNRECOVERABLE) - 0x10, SRC:(CCIINTDRC) - 0x35, Detail:An existing connection was forcibly closed by the remote host

Environment

Output Management Web Viewer 12.1

Cause

The issue can be caused from different issues relating to network connectivity such as protocol not allowed, port not allowed, or firewall blocking the connection.

Resolution

Begin checking if your port is blocked using command prompt and the netstat command to check your port.

If your port is blocked then use a different port or contact your network / security team to unblock the port.

Next, check what Tomcat version and protocol you are using. If you are trying to use a Tomcat version the does not use a supported protocol, then use a different protocol that is supported with the Tomcat version you are using.
Below is the table for protocols to Tomcat version:

  Java Nio Connector
NIO
Java Nio2 Connector
NIO2
APR/native Connector
APR
Classname AjpNioProtocol AjpNio2Protocol AjpAprProtocol
Tomcat Version 7.x onwards 8.x onwards 5.5.x onwards
Support Polling YES YES YES
Polling Size maxConnections maxConnections maxConnections
Read Request Headers Blocking Blocking Blocking
Read Request Body Blocking Blocking Blocking
Write Response Headers and Body Blocking Blocking Blocking
Wait for next Request Non Blocking Non Blocking Non Blocking
Max Connections maxConnections maxConnections maxConnections

 

If options before do not resolve your issue, then contact your internal network / security team to check if anything is blocking access for the connection to take place.

If nothing is able to resolve your issue then contact Broadcom Support.

Additional Information

For more information see The AJP Connector.