Siteminder: Error activating partnership <partnership_name>
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Siteminder: Error activating partnership <partnership_name>

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Article ID: 372746

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Updated On:

Products

CA Single Sign On Federation (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder) SITEMINDER

Issue/Introduction

Encountering error while attempting to activate the Federation partnership.

Environment

Siteminder 12.8.x

Cause

SPID http://example.com already existing in the PolicyStore and was not visible from the AdmUI GUI. Hence, not letting activate the partnership with duplicate SPID name.

smps.log

[5196/7328][Thu Jul 04 2024 04:40:35.677][SPPartSvc.cpp:2012][SPPartSvc::canBeActivated][ERROR][sm-xobfed-00950] Existing SAML 2.0 Service Provider is already active; Name: https://example.com (CA.SM::SAMLv2SP@21-000a6540-a050-1add-9111-0238ac14308d)
[5196/7328][Thu Jul 04 2024 04:40:35.677][SPPartSvc.cpp:2556][SPPartSvc::setActivated][ERROR][sm-xobfed-00490] setActivated failed.
[5196/7328][Thu Jul 04 2024 04:40:35.677][PartnershipService.cpp:2078][PartnershipService][ERROR][sm-xobfed-02330] PartnershipService failed.  Operation: 3

 

Resolution

 

1. Launch XPSExplorer from the command prompt.

2. Find object: Press F and Enter.

3. Search the Object ID reported to be already existing for the SPID in the smps log file.

Example:

As per the above logs snippet, search the duplicate object: 04-00054448-c7bb-1a8f-9111-0238ac14308d

4. Press D to delete the object. 

5. Attempt to activate the partnership <Partnership_Name>. It should activate the partnership.