Not able to find resource locale/Time Zone detail
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Not able to find resource locale/Time Zone detail

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Article ID: 372733

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

While creating a resource we enter attribute like locale and Time zone but when we try to check the same properties via Home > Resources or via Object > Resource we don't find these attributes.

How can we get details about resource locale and Time zone.

Environment

Component: Clarity

Release: 16.x 

Cause

The Resource created in system, is stored in distributed manner where some of the administrative settings are only shown under Administration > Resources, whereas the non-administrative  are shown on Home > Resources.

The attributes of Time Zone and Locale are not listed under object Resource, as those are stored as part of system object User.

Resolution

The below are some listed possible ways to query the Locale and Time Zone details of a user.

  • SQL

select csu.user_name, srm.first_name, srm.last_name,csu.locale, csu.timezone, srm.email from cmn_sec_users csu

join srm_resources srm on srm.user_id =csu.id

and srm.unique_name like '%username%';

  • REST API
    • API: /ppm/rest/v1/users/{userInternalId}
    • Example: ppm/rest/v1/users/1?fields=lastName%2Ctimezone%2Clocale%2CuserName%2CresourceName